ped

Редактор Photon

Синтаксис:

ped [-adfr] [-c функция] [-g строка]

[-h высота[%]] [-l настройка_локализации] [-p спецификация_файла]

[-S i|m|n] [-s сервер] [-t шаг]

[-w ширина[%]] [-x положение[%] [r]]

[-y положение[%][r]]

Поддерживаемые платформы:

Neutrino

Опции:

-a

Сохранить и загрузить файлы с атрибутами (специальные шрифты, полужирный, курсив и т.д.).

-c функция

Перейти после загрузки к указанной функции.

-d

Использовать список настроек локализации по умолчанию, в котором представлены следующие настройки локализации:

-f

Сохранять строки с мягким переносом как строки с жестким переносом.

-g строка

После загрузки перейти к определенной строке.

-h высота[%]

Высота окна, в пикселях или в процентах по отношению к высоте экрана (если введен символ %).

-l настройка_локализации

Использовать указанную настройку_локализации при кодировании и декодировании в процессе загрузки и сохранения файлов. Значение по умолчанию "C" для английского языка и UTF-2.

-p спецификация_файла

Использовать указанный шаблон спецификации файла по умолчанию в окне сохранения/открытия/загрузки файлов.

-r

Открыть файл в режиме "только для чтения" (режим просмотра).

-Si|m|n

Начальное состояние главного окна (свернуто, развернуто на весь экран, нормальный вид).

-s имя_сервера

Имя сервера Photon:

Имя_сервера

Использование сервера

путь_к_узлу

путь_к_узлу/dev/photon

полный_путь

полный_путь

относительный_путь

/dev/относительный_путь

-t шаг

Настроить шаг табуляции.

-w ширина[%]

Ширина окна, в пикселях или в процентах от ширины экрана (если введен символ %).

-x положение[%][r]

Координата x верхнего левого угла окна, в пикселях или в процентах от ширины экрана (если введен символ %). Если указан модификатор r, то координата определяется относительно текущей консоли.

-y положение[%][r]

Координата y верхнего левого угла окна, в пикселях или в процентах от высоты экрана (если введен символ %). Если указан модификатор r, то координата определяется относительно текущей консоли.

Описание:

Приложение ped представляет собой простой редактор, в котором поддерживаются только файлы в формате Unicode (UTF-8). В нем также предусмотрены простые функции поиска и замены.

Правка в редакторе ped.

Имя открытого в редакторе файла и путь к нему отображаются в заголовке окна. В нижней области окна отображаются индикаторы строк и столбцов, а также имя файла (без пути).

Примечание. При установке определенных параметров настройки программа ped вставляет в конце файла текстовый блок, который может вызвать конфликт с приложениями, считывающими файлы. При использовании параметров ped по умолчанию этот блок не добавляется. Необходимость добавления этого блока определяется путем выбора "Preferences" ("Параметры") в меню "Edit" ("Правка") и установки требуемых параметров на вкладке "Styles & Markers" ("Стили и маркеры").

Кнопка "Font" ("Шрифт") в правом верхнем углу указывает на шрифт текста в текущей позиции курсора. Нажатие этой кнопки аналогично выбору пункта "Font" ("Шрифт") в меню "Type" ("Вид") (Ctrl-Alt-F). Цветной прямоугольник рядом с текстовым полем указывает на цвет текста в текущей позиции курсора. Щелчок по этому прямоугольнику аналогичен выбору пункта "Color" ("Цвет") в меню "Type" ("Вид") (Ctrl-Alt-C).

Для выделения текста можно использовать следующие действия мыши:

Требуемый результат

Действие

Установка курсора

Один щелчок

Выделение слова, на котором установлен курсор

Двойной щелчок или
щелчок с удержанием клавиши Alt

Выделение текущей строки

Три щелчка

Выделение текущего абзаца

Четыре щелчка

Выделение всего текста

Пять щелчков

Расширение выделенной области

Щелчок с удержанием клавиши Shift

Выделение части текста

Перетаскивание с удержанием левой кнопки мыши

Копирование выделенной области в буфер обмена

Щелчок правой кнопкой мыши с удержанием левой кнопки


Для выделения, копирования, вставки и форматирования текста, а также для выбора пунктов меню можно вводить команды с клавиатуры.


Команды перемещения курсора

Если при перемещении курсора (см. далее) нажата и удерживается клавиша Shift, то весь текст по пути перемещения будет выделен.

Перемещение курсора

Сочетание клавиш

На один символ в направлении, заданном стрелкой

, ↓, ←, →

В начало строки

Home

В начало документа

Ctrl-Home

В конец строки

End

В конец документа

Ctrl-End

На одну страницу вверх

Page Up

На одну страницу вниз

Page Down

На одно слово вперед

Ctrl

На одно слово назад

Ctrl

К парной фигурной скобке или кавычке для символов "( )", "{ }", "[ ]", одиночной или двойной кавычек

F10


Примечание. Поиск соответствующих кавычек выполняется только в прямом направлении.

Команды удаления

Удаляемый объект

Сочетание клавиш

Строка

Ctrl-U

До конца строки

Ctrl-K

Символ справа от курсора

Delete

Символ слева от курсора

Backspace

Выделенный текст

Любая клавиша для удаления или вставки текста


После выделения текста, который требуется удалить, этот текст можно заменить путем нажатия любой клавиши ввода или удаления. Удаленный текст помещается в буфер обмена до тех пор, пока не будет заменен при следующем удалении или явном выполнении операции загрузки в буфер обмена.

Команды форматирования

Формат текста

Сочетание клавиш

Полужирный

Alt-B

Курсив

Alt-I


Если выделена часть текста, то формат применяется только к выделенному тексту. Если текст не выделен, то формат применяется к вводимому далее тексту.

Команды выравнивания

Выравнивание текста

Сочетание клавиш

Описание

По левому краю

Alt-L

Выравнивание текстовой строки, в которой установлен курсор, по левому краю.

По центру

Alt-C

Выравнивание строки, в которой установлен курсор, по центру.

По правому краю

Alt-R

Выравнивание текстовой строки, в которой установлен курсор, по правому краю.


Команды буфера обмена

Требуемый результат

Сочетание клавиш

Копирование выделенного текста в буфер обмена

Ctrl-C

Перемещение выделенного текста в буфер обмена (выделенный текст удаляется)

Ctrl-X или
Ctrl-Alt-X

Удаление текущей строки

Ctrl-U

Вставка текста из буфера обмена в текущую позицию курсора

Ctrl-V или
Ctrl-Alt-V


Примечание. В режиме замены каждый введенный символ сохраняется в буфере обмена.

Текст, замененный при вставке, помещается в буфер обмена.

Специальные команды

Требуемый результат

Сочетание клавиш

Описание:

Вызов Helpviewer

Ctrl-Alt-H

Поиск выделенного текста в Helpviewer.


Операции меню "File"

Пункт меню

Сочетание клавиш

Описание

Меню "File" ("Файл")

Alt-F

Отображение выпадающего меню "File".

New (Новый)

Ctrl-N или Alt-F-N

Очистка содержимого буфера и имени файла после подтверждения операции.

Open (Открыть)

Ctrl-O или Alt-F-O

Открытие нового буфера, замена текущего содержимого буфера после подтверждения операции.

Save (Сохранить)

Ctrl-S или Alt-F-S

Сохранение текущего содержимого буфера в файл с текущим именем.

Save As (Сохранить как)

Ctrl-A или Alt-F-A

Сохранение текущего содержимого буфера в файл с указанным именем.

Print (Печать)

Ctrl-P или Alt-F-P

Печать файла.

Exit (Выход)

Alt-X или Alt-F-X

Выход после подтверждения операции (если изменения в текущем буфере не сохранены).


Примечание. Файл также можно открыть путем перетаскивания из окна pfm в окно ped. Каждый перемещенный таким образом файл открывается в новом буфере.

Операции меню "Search"

Пункт меню

Сочетание клавиш

Описание

Меню "Search" ("Поиск")

Alt-S

Отображение выпадающего меню "Search".

Find (Найти)

Ctrl-F или Alt-S-F

Поиск следующего вхождения указанной строки.

Search & Replace (Поиск и замена)

Ctrl-R или Alt-S-R

Поиск следующего вхождения указанной строки и ее замена на вторую указанную строку.

Search & Replace (Поиск и замена)

F2

Поиск введенного в строке поиска текста.

Search & Replace (Поиск и замена)

F3

Заменить выделенный текст на текст, введенный в поле "Replace", и повторить поиск.

Goto Line (Перейти к строке)

Ctrl-G или Alt-S-G

Переход к указанной строке.


Если в открытом диалоговом окне "Find" курсор установлен в строке поиска, то при нажатии клавиши Enter выполняется поиск следующего вхождения значения поиска. При нажатии клавиши F2 поиск выполняется повторно; окно поиска в этом случае не обязательно должно быть активным или даже может быть закрыто.

Если в открытом диалоговом окне "Search and Replace" курсор установлен в поле "Replace", то при нажатии клавиши Enter операция повторяется. При нажатии клавиши F2 выполняется поиск следующего вхождения текста, введенного в строке поиска. При нажатии клавиши F3 выполняется замена выделенного текста, а затем поиск и выделение следующего вхождения тексте, введенного в строке поиска. При нажатии клавиши Esc окно "Search" закрывается.

Операции меню "Options"

В этом диалоговом окне можно изменить значения по умолчанию и кодировку файла.

Пункт меню

Сочетание клавиш

Описание

Меню "Options" ("Опции")

Alt-O

Отображение выпадающего меню "Options".

Defaults (Значения по умолчанию)

Ctrl-D или Alt-O-D

Вызов диалогового окна для настройки конфигурации по умолчанию для сеансов ped.

Encoding (Кодировка)

Ctrl-E или Alt-O-E

Выбор кодировки для использования в качестве фильтра при загрузке или сохранении файла.


В диалоговом окне "Defaults" можно установить такие параметры по умолчанию, как цвет фона или шрифта, шрифт, интервал табуляции, перенос текста, автоматический отступ и спецификацию файла, используемые при вызове диалоговых окон загрузки/сохранения.


Кроме того, можно определить необходимость резервирования атрибутов при загрузке или сохранении файлов (если эта опция активирована, то атрибуты сохраняются в комментарии C/C++ в конце файла). Данные атрибутов сохраняются в файле .ph/pedrc.

Цвета фона и текста применяются (обновляются) непосредственно при их выборе, что позволяет просмотреть изменения без необходимости закрытия диалогового окна.

Указанная кодировка принимается в качестве кодировки файла. При загрузке выполняется преобразование кодировки файла в UTF-8. При сохранении кодировка файла преобразуется из UTF-8. В самом редакторе используется кодировка UTF-8 (Unicode).

Примечание. Если текущая выбранная в редакторе кодировка не соответствует кодировке загружаемого файла, файл может быть загружен не полностью. Потребуется выбрать новую кодировку и повторно загрузить файл. Для преобразования одной кодировки в другую необходимо выполнить следующее:
  1. Выберите текущую кодировку файла.

  2. Загрузите файл (выполняется преобразование в UTF-8 с использованием выбранной кодировки).

  3. Выберите требуемую кодировку.

Сохраните файл (выполняется преобразование из UTF-8 в процессе сохранения с использованием новой кодировки).

Операции меню "Type"

Пункт меню

Сочетание клавиш

Описание

Меню "Type" ("Вид")

Alt-T

Отображение выпадающего меню "Type".

Font (Шрифт)

Ctrl-Alt-F или Alt-T-F

Открытие диалогового окна выбора шрифта.

Color (Цвет)

Ctrl-Alt-C или Alt-T-C

Открытие окна выбора цвета.


В диалоговом окне "Font" ("Шрифт") можно выбрать шрифт (гарнитуру, стиль и размер). Выбранный шрифт применятся к выделенному диапазону текста. Если диапазон текста не выделен, то выбранный шрифт применяется к вводимому далее тексту. (При вводе текста в текущей позиции курсора на кнопках шрифта отображается гарнитура и стиль этого текста.)

В диалоговом окне "Color" ("Цвет") можно выбрать цвет текста в выделенном диапазоне. В этом диалоговом окне определяется основной цвет для выделенного диапазона текста. Если диапазон не выделен, то выбранный цвет применяется к вводимому далее тексту. (При вводе текста в текущей позиции курсора на кнопке цвета отображается цвет этого текста.)

Примеры:

Запуск ped на сервере Photon в узле my_node:

ped -s/net/my_node/dev/photon

Запуск ped в определенном начальном положении (10,10) и с начальными размерами 200X300:

ped -x10 -y10 -h200 -w300

Правка простого текстового файла в японской кодировке Shift-JIS.

ped -a -l ja_JP.sjis

Файлы:

${HOME}/.ph/pedrc

Конфигурационный файл пользователя.