pfm

Файловый менеджер Photon

Синтаксис:

pfm [-h высота[%]] [-S i|m|n] [-s сервер]

[-w ширина[%]] [-x положение[%][r]] [-y положение[%][r]]

Поддерживаемые платформы:

Neutrino

Опции:

-h высота[%]

Высота окна, в пикселях или в процентах по отношению к высоте экрана (если введен символ %).

-Si|m|n

Начальное состояние главного окна (i свернуто, m развернуто на весь экран, n нормальный вид).

-s имя_сервера

Имя сервера Photon:

имя_сервера

Использование сервера

путь_к_узлу

путь_к_узлу/dev/photon

полный_путь

полный_путь

относительный_путь

/dev/относительный_путь

-w ширина[%]

Ширина окна, в пикселях или в процентах от ширины экрана (если введен символ %).

-x положение[%][r]

Координата x верхнего левого угла окна, в пикселях или в процентах от ширины экрана (если введен символ %). Если указан модификатор r, то координата определяется относительно текущей консоли.

-y положение[%][r]

Координата y верхнего левого угла окна, в пикселях или в процентах от высоты экрана (если введен символ %). Если указан модификатор r, то координата определяется относительно текущей консоли.

Описание:

Утилита pfm запускает графический файловый менеджер, позволяющий просматривать каталоги и файлы, создавать и править файлы и т.д.

Файловый менеджер Photon представляет файлы и папки в графическом виде. Для открытия папки и просмотра ее содержимого следует дважды щелкнуть по папке. Для открытия файла в связанном приложении (если существует привязка) следует дважды щелкнуть по файлу. Файловый менеджер также поддерживает операции перетаскивания: например, для перемещения файла в определенную папку достаточно перетащить его в нее. С помощью щелчка правой кнопкой мыши по файлу или папке можно просмотреть меню быстрого вызова, содержащее подмножество перечисленных далее команд.

Для быстрого перехода к элементу длинного списка можно ввести первые несколько символов имени файла или каталога.

Просмотр и правка файлов

Задача

Команда меню

Сочетание клавиш для быстрого запуска

Создать новый файл

File (Файл)-->New (Создать)-->File (Файл)

F3

Создать новую папку

File (Файл)-->New (Создать)-->Folder (Папка)

F4

Открыть новое окно файлового менеджера

File (Файл)-->New (Создать)-->Window (Окно)

Ctrl-N

Открыть выбранную папку

File (Файл)-->Open (Открыть)

Enter

Открыть выбранную папку в новом окне файлового менеджера

File (Файл)-->Open in Window (Открыть в окне)

Ctrl-Enter

Просмотреть выбранный файл *

File (Файл)-->View (Просмотр)


Править выбранный файл *

File (Файл)-->Edit (Правка)

Ctrl-E

Открыть выбранный файл с помощью определенного приложения

File (Файл)-->Open With (Открыть с помощью)

Shift-Enter

Открыть окно pterm, установлен путь к текущему каталогу

File (Файл)-->Open Terminal (Открыть терминал)

Ctrl-T

Обновить список файлов

File (Файл)-->Refresh (Обновить)

F5

Вывести текущий файл на печать

File (Файл)-->Print (Печать)

Ctrl-P

Вывести список файлов текущего каталога

File (Файл)-->Directory (Каталог)


Просмотреть или изменить свойства файла, в т.ч. размер, владельца, права на чтение/запись/выполнение и режим доступа.

File (Файл)-->Inspect (Свойства)

F9

Закрыть файловый менеджер Photon

File (Файл)-->Exit (Выход)

Alt-X


* Можно просматривать или изменять только типы файлов, связанные с приложением. Для добавления или изменения привязок типов файлов используется команда Edit (Правка)-->Associations (Типы файлов).

Перемещение, удаление и переименование файлов

Задача

Команда меню

Сочетание клавиш для быстрого запуска

Удалить выбранные файл или папку и поместить их в буфер обмена Photon

Edit (Правка)-->Cut (Вырезать)

Ctrl-X

Копировать выбранные файл или папку в буфер обмена Photon

Edit (Правка)-->Copy (Копировать)

Ctrl-C

Вставить папку или файл из буфера обмена Photon в текущий каталог

Edit (Правка)-->Paste (Вставить)

Ctrl-V

Удалить выбранные файл или папку

Edit (Правка)-->Delete (Удалить)

Delete

Переименовать выбранные файл или папку

Edit (Правка)-->Rename (Переименовать)

F2

Копировать файл или папку в каталог закладок или определенное местоположение

Edit (Правка)-->Copy To (Копировать в)


Выделить все файлы и папки в текущем каталоге

Edit (Правка)-->Select (Выделить)-->All (Все)

Ctrl-A

Выделить в текущем каталоге все файлы или папки, соответствующие указанному шаблону

Edit (Правка)-->Select (Выделить)-->Pattern (Шаблон)

Ctrl-S

Отменить выделение всех файлов и папок

Edit (Правка)-->Unselect (Снять выделение)-->All (Все)

Ctrl-U

Отменить выделение всех файлов и папок на основе указанного шаблона

Edit (Правка)-->Unselect (Снять выделение)-->Pattern (Шаблон)


Инвертировать текущее выделение (т.е. отменить выделение выделенных файлов, и выделить невыделенные файлы)

Edit (Правка)-->Invert Selection (Инвертировать выделение)

Ctrl-I

Просмотреть или изменить настройки файлового менеджера, в т.ч. отображение системных файлов, шрифты и поведение приглашений. См. раздел Установка параметров pfm далее.

Edit (Правка)-->Preferences (Параметры)

F10

Просмотреть или изменить привязки типов файлов к приложениям. От этих определений зависит возможность просмотра или открытия файла в файловом менеджере.

Edit (Правка)-->Associations (Типы файлов)

F11


Навигация

Задача

Команда меню

Сочетание клавиш для быстрого запуска

Просмотреть последний просмотренный список каталогов

Go (Переход)-->Back (Назад)

Alt-←

Просмотреть следующий просмотренный список каталогов (только после выполнения противоположной команды)

Go (Переход)-->Forward (Вперед)

Alt-→

Перейти на один уровень вверх в дереве каталогов

Go (Переход)-->Up One Level (На один уровень вверх)

Backspace

Просмотреть основной каталог текущего пользователя

Go (Переход)-->Home (Основной каталог)

F6

Добавить текущий каталог в список закладок

Bookmarks (Закладки)-->Add Current Directory (Добавить текущий каталог)

Ctrl-D

Удалить текущий каталог из списка закладок

Bookmarks (Закладки)-->Remove Current Directory (Удалить текущий каталог)

Ctrl-R

Просмотреть каталог, добавленный в закладки

Bookmarks (Закладки)-->Directory (Каталог)



Установка параметров pfm

Для установки параметров pfm выберите Edit (Правка)-->Preferences (Параметры). В диалоговом окне "Preferences" ("Параметры") можно настроить следующие параметры:

Параметр

Описание

Опции списка файлов

В этих параметрах настройки устанавливается необходимость отображения или скрытия системных файлов, начинающихся с "точки", и отображения списка папок перед файлами, не в алфавитном порядке.

Кодировка имени файла

Эти параметры настройки определяют, каким образом pfm отображает имена файлов с кодировкой, отличной от UTF8.

Шрифт списка файлов и рабочего списка

С помощью этих параметров настройки определяются шрифт, стиль и размер, используемые в списке файлов и закладках (рабочем списке).

Таймаут KeyFind

Этот параметр определяет максимальное время (в миллисекундах) между нажатием клавиш и сбросом функции поиска по вводу. Для деактивации сброса следует установить значение 0.

Копирование/перемещение, перезапись и удаление

Эти параметры настройки определяют, выводит ли утилита pfm приглашение перед копированием, перемещением или удалением файлов.


Примеры:

Запуск файлового менеджера Photon с использованием сервера Photon на узле my_node:

pfm -s/net/my_node/dev/photon


Запуск файлового менеджера Photon в определенном начальном положении (10,10) и с определенными начальными размерами 200х300:

pfm -x10 -y10 -h200 -w300